Installing YT

YT version 0.4 requires Julia version 0.5 or later, and may be installed just like any other Julia package:

julia> Pkg.add("YT")

This will also install the following dependencies, if you don’t have them installed already:

However, for YT to work, yt itself must be installed. YT version 0.4 requires yt version 3.3.1 or higher. The best ways to install yt are via pip or the Anaconda Python Distribution.

Once YT is installed, either

julia> import YT

to use it as a library, or

julia> using YT

to use it as an application, loading its methods into the current session’s namespace.